Bug #1755

Items refresh not picking up Acrane Font charm

Added by freedo over 2 years ago. Updated over 1 year ago.

Status:Resolved
Priority:Normal
Assignee:Kannkor
Category:Broken Feature(s)
Target version:-
vbulletin_issue_id:

Description

per description.  Running the refresh button in the ogrebot tab for items does not identify the Acrane Font charm.

 

Charm link: 

 

\aITEM -104068108 457064056:Arcane Font\/a

Drops from The Mist Reaver in Lost City of Torsis: The Shrouded Temple EH

 

do not know if it will need to be put in that ability pairs file been awhile since ive needed to go look at charm effects and if they are kicked off.

History

#1 Updated by Kannkor over 2 years ago

  • Status changed from New to Accepted

If you would like me to look at this ASAP, PM me on IRC and provide me a character that has the item. Otherwise I'll work on trying to acquire one.

#2 Updated by Kannkor over 2 years ago

  • Status changed from Accepted to Feedback Required

I can't reproduce this, with any item anyone seems to get that they say is broken. I get one, hit refresh, and it's in my list every time.

 

In order to fix this I'm going to need someone who can reproduce it and let me teamviewer in to see.

PM me on IRC if you have this happen and have time for me to teamviewer in.

#3 Updated by Kannkor over 2 years ago

Going to patch this out:

 

 

* OgreBotAPI
** Added: ItemDebug[ItemName]
*** Created for this: https://forge.isxgames.com/issues/1755
*** Usage: OgreBotAPI:ItemDebug["Arcane Font"]
*** Output: (14:57:12)[OgreBot]: ItemScanResults -> Value 1: TRUE. Value 2: TRUE. Value 3: TRUE
*** People who are having issues with items not scanning can run this command and provide me those values and we can see if we can figure out why it's happening.
*** For this command, the item must be in your inventory and not equipped.

#4 Updated by LittleOgress over 2 years ago

Different charm, same issue:

OgreBotAPI:ItemDebug["Spectral Beguiler's Ghostly Coin"]

ItemScanResults -> Equipment: Value 1: FALSE. Value 2: TRUE. Value 3: TRUE

 

#5 Updated by Kannkor over 2 years ago

In OgreBot 17.134 (or  17.133f on dev build) changes how it gets item data.

 

Try item scanning out again in this version out and let me know if it works.

#6 Updated by Kannkor over 1 year ago

  • Status changed from Feedback Required to Resolved

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 95.4 GB)