Project

General

Profile

Bug #2143

Property ${Target.OffersQuest} reply NULL with "Signature Quest" giver

Added by ethreayd over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
vbulletin_issue_id:

Description

When using echo ${Target.OffersQuest} on traditional Quest Giver, it replies "normal". On "Shiny Quill" ones, the quest givers for Signature, it replies NULL like for a non quest giver. I think it's not behaving as intended.

#1

Updated by ethreayd over 1 year ago

As asked I have run this script on a signature quest giver that repy NULL when echo ${Target.OffersQuest} :

function main() { variable index:string ActiveStates variable iterator ActiveStatesIterator variable int Counter Target:GetActiveStates[ActiveStates] ActiveStates:GetIterator[ActiveStatesIterator] if ${ActiveStatesIterator:First(exists)} { echo "${Target.Name} (ID: ${Target.ID})" echo "- ActiveStates:" Counter:Set[1] do { echo "-- ${Counter}. '${ActiveStatesIterator.Value}'" Counter:Inc } while ${ActiveStatesIterator:Next(exists)} echo "-=-=-=-=-=-=-" } }

 And here is the output :

Blaira Va'Tyrn (ID: 101663)
- ActiveStates:
-- 1. 'idle'
-- 2. 'status_quest_gives_storyline'
-- 3. 'tail'
-- 4. 'mood_idle'
-=-=-=-=-=-=-

#2

Updated by Amadeus over 1 year ago

  • Status changed from New to Resolved

Fixed/Updated in version 20200512.0005.

Also available in: Atom PDF