Project

General

Profile

Bug #1240

ogrebot disables ogreharvest

Added by pz over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
vbulletin_issue_id:

Description

makes harvesting in areas with aggro mobs pretty annoying.

#1

Updated by blammo over 7 years ago

primalz wrote:

makes harvesting in areas with aggro mobs pretty annoying.

 

I can confirm the following:

 

1. load ogreharvest

2. start ogre harvest - bot starts, moves, etc.

3. load ogre(combat)

4. ogre harvest is disabled

 

 

#2

Updated by blammo over 7 years ago

5. ogre harvest (without ogre combat loaded) will pause when combat starts, so it's aware of fighting.

#3

Updated by Kannkor over 7 years ago

  • Status changed from New to Resolved

Did the following changes. Will be patched with OgreBot-17.028

OgreHarvest

  • OgreHarvest is very old, and, to be honest, really poorly written for todays standards, and really annoying to work with, and really terrible in every way shape and form. I hadn't used OgreHarvest in months, if not years. I'm not going to be doing improvements, because it really needs a full rewrite, and I have no plans to do it. I did get a few updates done before rage quitting.
  • UI - Fixed about 100 things wrong with the UI. No longer is multi-coloured. No longer has massive white borders around random buttons.
  • UI - Fixed the stats window for colour/border also.
  • Stats window
    • Some people have reported 'double counting' this is an ISXEQ2 bug that has been reported. It will count resources * the number of In-game chat windows you have open. IE: If you have 1 chat window open, it's resources*1 (which is correct). If you have two chat windows opens, it's Resources*2. (Multiple tabs are fine, but multiple windows cause this issue).

Successfully worked with the following tests:

Loaded OgreHarvest, started it. (It was moving/harvesting).

Loaded Ogrebot.

OgreHarvest continued like normal.

Paused Ogrebot, OgreHarvest stopped (as expected).

Resumed Ogrebot, OgreHarvest continued.

Also available in: Atom PDF