Project

General

Profile

Bug #2234

Window not returning values

Added by Noobbotter 11 months ago. Updated 11 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
vbulletin_issue_id:

Description

When attempting to access an EVEWindow Datatype i am able to successfully access the window, however most of the Members and Button Methods are not available.

 

CCP has started adding in new dialog boxes that still extend the EVEWindow, but must be implemented differently.

 

To Replicate the issue, choose any ship (or even your capsule is fine) Undock from the station in Gulfondi and warp over to the system Aeddin and jump in.  From there open The Agency window, and select the Encounters tab,  slect Homefront Operations. Select the system Aeddin, and you should see a "Metaliminal Meteoroid: Minatar Mining" Select "Warp to location".  Once you finish warp, you will land on grid with an accelleration gate,  and a blue "Transmission" will pop up.   Do not take the accelleration gate,  This blue window is the window that has the issue, Do not close it,  you may need to warp out and back in and that may not reset.  In the Homefront Operations window you should be able to find another one (might have a different name but all have this transmission Window pop up on entry) in surrounding systems.

 

While the window is up.   you can do the following commands : 

 

Echo ${EVEWindow[byCaption,Transmission]}   and the result will be "Syntax: Echo <text>"   Which was odd.  but when i did the following i assumed that meant it found the window, but couldn't get any of the members.

Echo ${EVEWindow[byCaption,slkdfjg]}  and the result will be "NULL" as expected.   This indicated that it was getting something with the above command.

Echo ${EVEWindow[byCaption,Transmission].Caption}   returns "Transmission" - Expected

Echo ${EVEWindow[byCaption,Transmission].Text}  Returns NULL - Unexpected - here is the bug.

Echo ${EVEWindow[byCaption,Transmission].NumButtons}  Returns 1 - Expected

${EVEWindow[byCaption,Transmission][1]:Press}   (i may have done the method code for labishscript wrong here?  but i tried in .NET and had the same issue.)   Nothing happens, nothing appears in the log, the window doesn't close - This is the other Bug.

 

#1

Updated by Noobbotter 11 months ago

Edit:  It's worth noting that i am unable to do ${EVEWindow[byName,Transmission]}  it returns NULL,  so i guess the name is something different. Also i have no idea how i would find out the ID to try and grab it.

 

Another issue that seems to be related to windows.   On the EVE TLO there seems to be a method called "GetEveWindows()"  When i run that, i get 0 results,  even if i have 3, 4, 5+ windows open in the client.

Also available in: Atom PDF