Project

General

Profile

Bug #1179

EVEWindow[telecom]:ClickButtonClose no effect

Added by pz over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
vbulletin_issue_id:

Description

Missions give "Information" windows with just a [Close] button.

echo ${EVEWindow[active]} gives "telecom" (no quotes ofc).

Tried EVEWindow[telecom]:ClickButtonClose and EVEWindow[byName,"telecom"]:ClickButtonClose with no effect, also tried :ClickButtonCancel same.

 


Files

afb7ca1cb2[1].jpg - Example1 (30.9 KB) pz, 2014-09-22 06:28 AM

8a8eb3ee82[1].jpg - Example2 (35.8 KB) pz, 2014-09-22 06:28 AM

#1

Updated by pz over 7 years ago

Also tried EVE:CloseAllMessageBoxes with no effect.

#2

Updated by Stealthy over 7 years ago

I can confirm all of the above. This is a very, very old issue.

#3

Updated by Amadeus over 7 years ago

  • Status changed from New to Feedback Required
  • Assignee set to Amadeus

OK, since this is difficult to recreate for someone that doesn't run a lot of missions, I have added two DIFFERENT things and I want you to test both (even if one works, please test the other method as soon as you get the window again):

  • EVEWindow[telecom]:ClickButtonClose
  • EVEWindow[telecom]:Close

Once you let me know which (or both) that works, I'll make sure they both work properly.  There is a method that I'd prefer to use; however, I wasn't sure if it would work.  So, once I get some feedback on which (or both) of these that works, I'll fix both methods.

(NOTE:  These windows are handled completely different than any other type of windows.  It's really silly design.)

#4

Updated by pz over 7 years ago

Confirmed both work in .0005

#5

Updated by Amadeus over 7 years ago

  • Status changed from Feedback Required to Closed

Also available in: Atom PDF